0
\$\begingroup\$

As seen in the image here or anywhere else in codegolf:

enter image description here

The extra part is apparently : "– "

I believe it's a bug?

\$\endgroup\$
2
  • \$\begingroup\$ I suspect you have changed the default character set for loading codegolf in your browser. Reset it to the default (or UTF-8) and it should work just fine. \$\endgroup\$
    – Oded
    Sep 11, 2013 at 13:44
  • \$\begingroup\$ Thanks Oded. Whoever be the reason, I don't find the issue anymore as well. I had filed a bug at chrome though... \$\endgroup\$
    – loxxy
    Sep 11, 2013 at 14:48

1 Answer 1

2
\$\begingroup\$

The character is U+2013, "en dash". It seems to be a display problem for your browser, not of the site in general.

Another way to write it is –, and it should appear in your browser as (or – in roman text). Does that appear correctly for you?

\$\endgroup\$
6
  • \$\begingroup\$ Nope. it's same. Interestingly, when I edit in debug mode it renders correctly but not in browser. \$\endgroup\$
    – loxxy
    Sep 5, 2013 at 12:01
  • \$\begingroup\$ Does it work for you if you use a different browser? I'm trying to see if the problem is with your browser or with your computer's locale settings, in general. \$\endgroup\$ Sep 5, 2013 at 12:08
  • \$\begingroup\$ Yup, problem exists in one browser only. Works well in all others... \$\endgroup\$
    – loxxy
    Sep 5, 2013 at 12:13
  • \$\begingroup\$ Strange, I can't reproduce it anywhere else than codegolf in the same browser \$\endgroup\$
    – loxxy
    Sep 5, 2013 at 12:23
  • \$\begingroup\$ But they haven't used –, so it's likely the browser is just using the wrong unicode encoding for some reason. \$\endgroup\$
    – gnibbler
    Sep 5, 2013 at 17:44
  • \$\begingroup\$ @gnibbler, when I view source in Chrome or Firefox I see – . Maybe they serve slightly different HTML to different browsers. \$\endgroup\$ Sep 6, 2013 at 9:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .